6

I try to run Kiln 0.4.0 on a VirtualBox NixOS (Host Windows 10).

NixOS (VirtualBox appliances) https://nixos.org/nixos/download.html

After executing:

ln -sf $(nix-build tezos-bake-central -A exe --no-out-link)/* app/

Everything runs through (about 10-15 minutes) And then i am getting the following error:

error: build of '/nix/store/x5b7bcd0vngbn1z5dhpmb6kcndac8wf1-cabal2nix-obelisk-generated-static.drv' failed

I've tried to execute (after CDed into "app"): ./backend --network mainnet

but I then got the error: -bash: ./backend: No such file or directory

[Complete Error Log] https://github.com/Blindripper/Docs/blob/master/kiln%200.4.0.%20NixOs%20Error.txt

Commit Hash: fa8be8dea50689697bbf456109a15e74e7f5981f

9
  • 1
    Sorry to ask, should the backing tag be actually baking? It contains only one question.
    – mico
    Feb 2 '19 at 14:31
  • 1
    "No such file or directory" is clear because the build failed and therefore the binary cannot be there.
    – jdsika
    Feb 2 '19 at 22:26
  • 1
    Did you setup the nix cache? gitlab.com/obsidian.systems/tezos-baking-platform/blob/develop/…
    – jdsika
    Feb 2 '19 at 22:34
  • 1
    Can you please provide more of the logs from before and after error: build of '/nix/store/x5b7bcd0vngbn1z5dhpmb6kcndac8wf1-cabal2nix-obelisk-generated-static.drv' failed? Feb 4 '19 at 17:39
  • 1
    The most common cause of failed builds I've seen is due to running out of memory. Part of the static build step requires a really large amount of memory. Feb 4 '19 at 18:32
6

This line of your log suggests that your VM is out of memory. Could you try raising the allocated memory for your guest and see if that fixes it?

3
  • For posterity, the line is ghc: internal error: Unable to commit 1048576 bytes of memory Feb 5 '19 at 13:29
  • Thx will try it this evening and will give feedback. I thought "echo 1 > /proc/sys/vm/overcommit_memory" would vanish all Mem problems but i will try to raise the general memory of the machine. Feb 5 '19 at 13:29
  • Thx guys it works now :-) It was the memory. Raised it to 4GB (from 2GB). Feb 5 '19 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.