1

I have a public node that I'm trying to connect to my private node, but the connection keeps getting rejected, even after using trust peer and trust address in both of them. I also have tried from a different public node, with the same error, and ports are open (unless this needs some weird ports different than the usual ones).

The error message shown is:

./mainnet.sh admin-client connect address <IP>:9732
Error:
  Rejected peer connection: rejected socket connection.

Any ideas? Thanks!

1

Is is not possible to connect from another node to a node that is in private mode. You must establish the connection from the private node to a trusted node, not the other way round.

Although the node that is connected to does not need to trust the private node to allow the connection, it is recommended to have this setting in its config file to have a stable connection.

1
  • Thanks. I was going crazy because I was getting that error almost every time, but I was so sure it was possible to connect :facepalm: Oct 23 '19 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.