On 18th October 2019, I tried to open my TezBox as usual with the password that I have been using since I got my Tezbox. While I did not change the password, my TezBox kept giving me a message saying "Incorrect Password" (repeat, I did not change my password). So I tried to open my TezBox on a different desktop via connection to my Nano Ledger (which I use for my offline wallet). I managed to open my TezBox with the old same password but then all my KT1 accounts have disappeared. Only the manager account (TZ1 account) is there. Fortunately, I can check my KT1 accounts on TEZOS.ID (I suppose TzScan is gone) and they still exist (thank God). I would very much appreciate if any one could help me solve this issue? How could I get my KT1 accounts back on my TezBox? Many thanks in advance.

2 Answers 2


There are a couple of things happened this week. Sadly, TzScan announced on their twitter account that they are going down https://twitter.com/TzScan/status/1183672990493478912. But there is still a good choice of alternatives, one of them you mentioned is tezos.id, another is tzstats.com.

The second thing is the new update Bybilon was injected that removes KT1 contracts for deligation but allowing to delegate directly from TZ1. You can find a bit of information on the voting and links to the change proposal > https://tzstats.com/election/13

In the Tezbox I'm still figuring out how to transfer the funds from KT1 back to TZ1.

Hope it helps.

  • Thank you very much for your answer. On TezBox, I have finally figured out how to fix my issues. On Manager account (TZ1), there is a tab called "Options" and if you click it, you will see "Import KT1 Account" section. What I did was that I copied each of my KT1 account addresses, one by one, onto Tzstats (or Tezos id) first and copy those KT1 account addresses by using Tzstas' copy address bottom and past them onto the "Import" box one by one to import my KT1 accounts back into my Texbox.
    – Ketaru
    Commented Oct 19, 2019 at 10:56

As reported by TezBox, this is a known-bug that happened post-Babylon and will require the clearing and restoring of the wallet (from seed, private key, ICO wallet or hardware token).

Once the main wallet is restored, you may need to re-import your KT1 address(s), by using Import KT1 Account under Options.

I copy the excerpt that mentions this issue:

Incorrect Password

This is a TezBox specific bug, and we’re really sorry to all those that saw this screen. If you’ve tried to unlock your wallet for the first time after the upgrade and you see this (and you know you’ve entered your password correctly) than you are affected by this bug.

Solution: Simply click Continue (to get rid of the error prompt), and hit click the Clear TezBox on the password screen. You will then return to the start screen when you can Restore your wallet (from your seed, private key or ICO details) or re-link your hardware wallet.

Cause? It took us a while to debug this issue as it never came through any testing, but we believe that accounts created using an early version of the wallet changed the format of the stored data which wasn’t compatible with the upgrade. We’ll be sure to do more unit testing with older versions of our wallet in future.

  • Thank you. I have a question. I am facing the same issue (an "incorrect password" message) again as of 13/3/2020. So I believe I need to clear TezBox once again and restore by re-linking TezBox with my Nano S. I did not take a note of the private key for my XTZ stored on my Nano S ledger. I just want to make sure, before clearing my TezBox, that I would not need my Private Key to restore my TezBox. Last time when the Babylon update took place, I managed to restore my TezBox by just re-linking my hardware wallet to TezBox with a right HD pass but not with the private key. Many thanks.
    – Ketaru
    Commented Mar 13, 2020 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.