0

I am using TezBox to make a transaction from tz1fVCLCR9zKMgGBTvuxcQufktXwwXJVC5KE to my smart contract KT1BNuzMP54AoPNWQF45LkjhcFjW3A48rcHb. In the parameter field, I use Left "tz1PkBUSrV2kSQYvsuwfz5kWXzigtkjR4i4o". I put a high gas limit, 20k. The transaction is accepted, it says "Awesome". But after waiting for a while and checking on TzScan, nothing appears. The smart contract has no transaction, storage is not updated, etc... When I take a look at the Network tools from Chrome, it seems like everything is fine. I don't understand why the transaction doesn't show on my smart contract while TezBox still accepts it and says "Awesome!"...

I tried using CLI and it worked fine. My command was

./tezos-client transfer 0 from tz1fVCLCR9zKMgGBTvuxcQufktXwwXJVC5KE to KT1BNuzMP54AoPNWQF45LkjhcFjW3A48rcHb --arg 'Left "tz1PkBUSrV2kSQYvsuwfz5kWXzigtkjR4i4o"' --burn-cap 0.012

And it worked fine. I was instantly able to see the transaction in my smart contract, as well as the updated storage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.