5

I'm running Alphanet on a Mac OSX and have everything running fine, but have hit a roadblock trying to activate an account with a faucet JSON. Totally new to Tezos.

I run the command:

./alphanet.sh client activate account myfaucet with "container:tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json"

Then I regularly get this error message:

Error:
Erroneous command line argument 5 (file:/tmp/tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json).
File doesn't exist: 'file:/tmp/tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json'

When I run the ./alphanet.sh shell and look in the file directory there, I can see the file in /tmp.

I've also tried specifying the path to the file on my system - e.g.

./alphanet.sh client activate account myfaucet with "container:/Users/myusername/Development/Tezos/tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json"

I get the same error as above. I don't know if Docker cannot attach the file to its image or I'm missing a parameter somewhere in my setup.

The node is fully bootstrapped, I've created a wallet without tezzies, and everything seems to run normally. However, I just cannot add tezzies via a faucet.

I've looked all around the internet and see the problem appear in a few places, but no real solutions. Any help would be wonderful!

3

You could use Docker's cp command as a workaround.

In your case it would be something like:

docker cp tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json alphanet_node_1:/home/tezos/tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json
./alphanet.sh client activate account myfaucet with tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json
| improve this answer | |
  • 1
    Thank you! That ended up working with one additional move. I needed to put the file into the /home/tezos directory of the docker container. So the original command can be "docker cp tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json alphanet_node_1:/home/tezos/tz1Zvjxu9Vzt76uRLtV6CHZMPu1zKA5YV4QX.json" – bmagierski Aug 3 '19 at 14:18
  • The other issue I was facing I noticed was that the client was not fully bootstrapped. I originally ran the command "$./alphanet client bootstrapped" and it ended stating that it was "bootstrapped". However, when looking at the time stamps, it timed out early. I needed to restart the node multiple times and re-run bootstrapped to get the client fully bootstrapped. Operations cannot be injected until the time stamp is current. – bmagierski Aug 3 '19 at 14:22
  • Thanks! I updated the answer according to your comment. – Klassare Aug 3 '19 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.