8

I was trying to connect eztz-cli to my locally running containerized (via docker) tezos node. These are the steps I followed:

  1. Start the node with rpc enabled by running ./alphanet.sh start --rpc-port 6160
  2. Set the provider by running eztz provider localhost:6160

After this, when I run commands like eztz balance *some account address here* or eztz freeAccount main account1, it returns Error: Error: Protocol not supported. I have tried digging into the source code of eztz-cli and eztz, but couldn't find the root cause. Any help is appreciated.

  • 1
    I'm somewhat speaking through my hat... but are all your nodes and clients running on alphanet? If one of them is running either zeronet or betanet, that's probably your problem right there. – user79 Jan 29 at 22:10
  • 1
    @user79 I don't think that's the problem, since the docker images pulled are automatically chosen by the script by looking at its own name. So for running a mainnet node, the script should be renamed and run as ./mainnet.sh. tezos.gitlab.io/alphanet/introduction/… contains information about how this process takes place. – Kartik Shah Jan 29 at 22:25
5

Last commit to eztz-cli was in November of 2017. So I would consider it outdated. The query in getBalance() is no longer valid. It's no longer possible to create free accounts, you need to use the faucet instead. Try to use eztz directly instead and it should work.

  • 2
    This is correct - eztz-cli will become updated in the near future. – Stephen Andrews Feb 1 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.