5

I'm receiving this error message after a couple of transactions have failed. Is it the nonce? I was expecting the pre-apply call would take care of it.

Now I'm receiving this message:

branch refused (Error:\n Counter 1191226 already used for contract tz1Pwg.. (expected 1191227)

Any ideas? Anywhere where error messages are explained? Google can't help.

Update: Error messages are here: https://tezos.gitlab.io/mainnet/api/errors.html Though it seems like its incomplete as I have received several messages not found in the list.

5
  • This can sometimes happen in surprising ways. I recommend describing what you did and what you observe in more detail. Perhaps reproduce in a sandbox environment, if you can, or scrub out your real details if you like. Also, inspecting the contents of /chains/main/mempool/pending_operations might be illuminating. I have a vague idea what causes this but I can give a better answer with more details. Worst case, if I'm right, the problem should go away automatically after ~60 blocks.
    – Tom
    Jun 5 '19 at 0:14
  • Thanks for your comments Tom. It seemed to be a previous transaction which failed (after receiving a success operation tx). The fee was too low. Friendlier error messages should be a focus. Now im getting another error (in a new post).
    – Vindberg
    Jun 6 '19 at 7:36
  • Another update: It happens when using eztz js and the previous transaction hasn't been committed to a block yet. Will have to find a way in eztz to define the nonce manually if I want to send a second transaction quickly after another. Any insight on this Tom?
    – Vindberg
    Jun 6 '19 at 9:40
  • 1
    Right, that sounds like two separate causes. In the case of low fees, the problem involves the node. In the case of multiple ops per block, it is purely a client (eztz) problem, I guess. Maybe an answer could try to explain all the common causes of this error...
    – Tom
    Jun 6 '19 at 16:59
  • Did you solved this issue? seems pretty common when trying to send multiple tx, one after the other Jul 31 '19 at 16:30
1

I also faced same error - "Branch refused" sometimes for contract deployment on tezos network. This error occurs when we use wrong network url. First of all make sure your network provider link is correct. And try by changing gas price and maximum limit values while deploying. This might help you out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.