5

I have the following P2P settings in my config file for my public nodes, it seems to be okay, and is bootstrapping from the foundation nodes but I am interested to hear if there could be any improvements. Are there any additional settings that would make it work better? Are the values entered sensible?

        "p2p": {
            "private-mode": false,
            "bootstrap-peers": [ "dubnodes.tzbeta.net ", "franodes.tzbeta.net ", "sinnodes.tzbeta.net" , " nrtnodes.tzbeta.net" ],
            "listen-addr": "0.0.0.0:9732",
            "limits": {
              "authentication-timeout": 5,
              "min-connections": 100,
              "expected-connections": 100,
              "max-connections": 500,
              "backlog": 20,
              "max-incoming-connections": 100
            }
          }
1
  • One note: by setting min_connections = expected_connections, you cause a certain calculation in the p2p code step_min = (expected - min) / 3 to result in 0. (Search for step_min in the code.) It is not immediately clear to me whether this is troublesome, but it is an edge case... I could try to explain the apparent significance of min/expected/max in a specific question about them -- this question seems too broad to answer.
    – Tom
    May 31 '19 at 21:31
2

Use ./tezos-node config update --connections=300 to fix your config file, as Tom said, those numbers should not match. Then restart tezos-node. Make sure your firewall is open, and any routers are port-forwarding to port 9732. You should also enable the RPC while you are at it config update --rpc-addr=127.0.0.1:8732 so that you can use other tools which interface with the node API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.