4

I'm following the instructions found here:

https://gitlab.com/obsidian.systems/tezos-bake-monitor/blob/develop/docs/ImportingChainHistory.md

and here:

https://www.tzdutch.com/quicksync/

The kiln node is unable to start and the GUI says "FAILED".

The logs say:

01-May-2019 11:16:29LevelWarn""("Process exited unexpectedly:",Id {unId = 1})
01-May-2019 11:16:34LevelError""PublicNodeError_RpcError (RpcError_HttpException "HttpExceptionRequest Request {\n  host                 = \"127.0.0.1\"\
May  1 11:16:40 - node.main: Starting the Tezos node...
May  1 11:16:40 - node.main: No local peer discovery.
May  1 11:16:40 - node.main: Not listening to P2P calls.
May  1 11:16:40 - node.main: Peer's global id: idqzRThCmDPoP7bRETbxVkDwPxFc47
May  1 11:16:40 - node.worker: bootstrapping chain...
tezos-node: Error:
              Permission denied
  • What does ls -l ~/.tezos-node/ show? – Richard Ayotte May 2 at 17:52
  • drwx------ 4 kiln kiln 4096 May 2 15:52 NetXdQprcVkpaWU – Anon75 May 2 at 20:01
  • 1
    Did you definitely do step 5? sudo cp -r ~/.tezos-node/context ~/.tezos-node/store /var/lib/kiln/data-dir/tezos-node/[chain-id]/ sudo chown -R kiln:kiln /var/lib/kiln/data-dir/tezos-node/[chain-id] – Tom Smalley May 3 at 16:52
  • (I assume you are using the debian distro on ubuntu?) – Tom Smalley May 3 at 16:53
  • you were right, I didn't do chown in step 5. I simply unzipped the latest.tar.lz4 file and tried to start the node. it works now! I struggled because I don't know llinux and couldn't follow the instructions. the code snippets aren't runnable, I had to edit [chain-id] with NetXdQprcVkpaWU. didn't realize the difference in step 5 of the source/debian instructions. – Anon75 May 4 at 4:28
2

This comment solved it

Did you definitely do step 5? sudo cp -r ~/.tezos-node/context ~/.tezos-node/store /var/lib/kiln/data-dir/tezos-node/[chain-id]/ sudo chown -R kiln:kiln /var/lib/kiln/data-dir/tezos-node/[chain-id]

This is the answer:

sudo chown -R kiln:kiln /var/lib/kiln/data-dir/tezos-node/[chain-id]

or for production:

sudo chown -R kiln:kiln /var/lib/kiln/data-dir/tezos-node/NetXdQprcVkpaWU
0

As of v0.6.0 Kiln now supports snapshot import through its user interface, so you should no longer need to manually copy/paste chain history from another node into Kiln's directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.