3

I'm trying to get a node running on alphanet. I am following the documentation here: http://tezos.gitlab.io/master/introduction/howtoget.html

When I run make build-deps, everything goes well except these two lines:

[ERROR] The compilation of mtime failed at "/home/username/.opam/opam-init/hooks/sandbox.sh build ocaml pkg/pkg.ml build --pinned false --with-js_of_ocaml true".

[ERROR] The compilation of ptime failed at "/home/username/.opam/opam-init/hooks/sandbox.sh build ocaml pkg/pkg.ml build --pinned false --with-js_of_ocaml true".

What kind of problems would this cause and does this need to be fixed before I proceed?

EDIT: Adding more information about the error.

#=== ERROR while compiling ptime.0.8.4 ========================================#
# context     2.0.1 | linux/x86_64 | ocaml-base-compiler.4.07.1 | git+https://gitlab.com/tezos/opam-repository.git#ebc2de016e52e8b77f250df174512a793b2fb0e5
# path        ~/tezos/_opam/.opam-switch/build/ptime.0.8.4
# command     ~/.opam/opam-init/hooks/sandbox.sh build ocaml pkg/pkg.ml build --pinned false --with-js_of_ocaml true
# exit-code   1
# env-file    ~/.opam/log/ptime-32735-d682c6.env
# output-file ~/.opam/log/ptime-32735-d682c6.out
### output ###
# pkg.ml: [ERROR] cmd ['ocamlbuild' '-use-ocamlfind' '-classic-display' '-j' '4' '-tag' 'debug'
# [...]
#      'src-os/ptime_clock.cmxa' 'src-os/ptime_clock.cma'
#      'src-os/ptime_clock.cmx' 'src-os/ptime_clock.cmi'
#      'src-os/ptime_clock.mli' 'src-os/dllptime_clock_stubs.so'
#      'src-os/libptime_clock_stubs.a' 'src-os/ptime_clock_top.a'
#      'src-os/ptime_clock_top.cmxs' 'src-os/ptime_clock_top.cmxa'
#      'src-os/ptime_clock_top.cma' 'src-os/ptime_clock_top.cmx'
#      'src-jsoo/ptime_clock.a' 'src-jsoo/ptime_clock.cmxs'
#      'src-jsoo/ptime_clock.cmxa' 'src-jsoo/ptime_clock.cma'
#      'src-jsoo/ptime_clock.cmx' 'src-jsoo/ptime_clock.cmi'
#      'src-jsoo/ptime_clock.mli' 'test-os/min_clock_os.ml'
#      'test-jsoo/min_clock_jsoo.ml' 'test-jsoo/min_clock_jsoo.html']: exited with 10


#=== ERROR while compiling mtime.1.1.0 ========================================#
# context     2.0.1 | linux/x86_64 | ocaml-base-compiler.4.07.1 | git+https://gitlab.com/tezos/opam-repository.git#ebc2de016e52e8b77f250df174512a793b2fb0e5
# path        ~/tezos/_opam/.opam-switch/build/mtime.1.1.0
# command     ~/.opam/opam-init/hooks/sandbox.sh build ocaml pkg/pkg.ml build --pinned false --with-js_of_ocaml true
# exit-code   1
# env-file    ~/.opam/log/mtime-32735-4197d2.env
# output-file ~/.opam/log/mtime-32735-4197d2.out
### output ###
# pkg.ml: [ERROR] cmd ['ocamlbuild' '-use-ocamlfind' '-classic-display' '-j' '4' '-tag' 'debug'
# [...]
#      'src/mtime_top.a' 'src/mtime_top.cmxs' 'src/mtime_top.cmxa'
#      'src/mtime_top.cma' 'src/mtime_top.cmx' 'src/mtime_top_init.ml'
#      'src-os/mtime_clock.a' 'src-os/mtime_clock.cmxs'
#      'src-os/mtime_clock.cmxa' 'src-os/mtime_clock.cma'
#      'src-os/mtime_clock.cmx' 'src-os/mtime_clock.cmi'
#      'src-os/mtime_clock.mli' 'src-os/dllmtime_clock_stubs.so'
#      'src-os/libmtime_clock_stubs.a' 'src-jsoo/mtime_clock.a'
#      'src-jsoo/mtime_clock.cmxs' 'src-jsoo/mtime_clock.cmxa'
#      'src-jsoo/mtime_clock.cma' 'src-jsoo/mtime_clock.cmx'
#      'src-jsoo/mtime_clock.cmi' 'src-jsoo/mtime_clock.mli'
#      'test-os/min_os.ml']: exited with 10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.