5

I'm trying to run a local instance of tzscan: https://gitlab.com/tzscan/tzscan But I'm not 100% sure about how to fix the following errors:

Error log:
Error:
[644.1] 

File "./libs/ez-api/libs/ez-api/ezEncodingJS.ml", line 80, characters 26-32:
Error: Unbound module Js

Error:
rule 644: target ./_obuild/ez-api-js/ezEncodingJS.cmo not built
Error:
[625.1]

File "./libs/base58-blockies/base58Blockies.ml", line 82, characters 7-32:
Error (warning 3): deprecated: module Tyxml_js
Will be removed past 2019-04-01. Use Js_of_ocaml_tyxml.Tyxml_js instead.

Error:
rule 625: target ./_obuild/base58-blockies/base58Blockies.cmi not built
Error:
rule 625: target ./_obuild/base58-blockies/base58Blockies.cmo not built
Makefile:44: recipe for target 'all' failed

Is there anyone that can help, or is there more info I need to post to be able to?

0

Your problem is related to the dependency js_of_ocaml. Some backward incompatibilities have been introduced in the API of the last versions (3.3.0 and 3.4.0).

Try to manually downgrade by doing opam install js_of_ocaml.3.2.0 js_of_ocaml-compiler.3.2.0 js_of_ocaml-lwt.3.2.0 js_of_ocaml-tyxml.3.2.0 js_of_ocaml-ppx.3.2.0, "clean up" everything and retry to build...

0

No unfortunately the last release on http://gitlab.com/tzscan/tzscan is only compatible with js_of_ocaml.3.4.0, it will not work with 3.3.0 or 3.2.0. So there must a problem in your switch. Could you provide us with the result of opam list?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.