2

Kiln seems to be installed and enabled. At least that's what systemctl list-unit-files --type=service | grep kiln suggests, which shows "kiln.service enabled". I have rebooted several times, but typing http://localhost:8000 in Firefox always tells me "Unable to connect". What could be the cause of this? Ubuntu is based on Debian, so the .deb file should work. I first tried installing it via dpkg, but that failed. I think it was a dependencies issue, since using gdebi seemed to solved the issue. Could it be, that I still need to hand-install some Ubuntu specific stuff for it to run in my browser?

6
  • Have you tried http://127.0.0.1:8000 in case your loopback is not enabled? Also, is the systemd service showing that it's active and running without error? You can also look at logs with journalctl -u kiln -ef Apr 19 '19 at 14:30
  • -- Logs begin at Fri 2019-04-19 10:22:48 CEST. -- Apr 19 23:15:14 user systemd[1]: kiln.service: Unit entered failed state. Apr 19 23:15:14 user systemd[1]: kiln.service: Failed with result 'exit-code'. Apr 19 23:15:19 user systemd[1]: kiln.service: Service hold-off time over, scheduling restart.
    – ciTEZen
    Apr 19 '19 at 21:34
  • Apr 19 23:15:19 user systemd[1]: Stopped Kiln. Apr 19 23:15:19 user systemd[1]: Started Kiln. Apr 19 23:15:19 user run-kiln[19660]: unshare: unshare failed: Operation not permitted Apr 19 23:15:19 user systemd[1]: kiln.service: Main process exited, code=exited, status=1/FAILURE over and over again
    – ciTEZen
    Apr 19 '19 at 21:35
  • What version of Ubuntu? Apr 21 '19 at 4:10
  • I am using Debian. Isn't Ubuntu just a repackage of Debian? Fredcy recommends using Debian...
    – ciTEZen
    Apr 22 '19 at 8:39
2

Version 0.5.1 of Kiln has a Debian package (.deb) that, ironically, doesn't work on Debian. It only works on Ubuntu. This is because Ubuntu enables user namespaces by default but Debian does not. You can manually enable them on Debian by following the "permanent" instructions here: https://unix.stackexchange.com/a/303214/197651

echo 'kernel.unprivileged_userns_clone=1' > /etc/sysctl.d/userns.conf

This should be fixed in an upcoming release by having the installer do this step for you.

7
  • Great! This worked. You are amazing! Thank you so much.
    – ciTEZen
    Apr 23 '19 at 20:29
  • Just noticed, that the node has grown bigger than what I can download locally :-( So, "bonus" question, I guess: how do I configure Kiln to use a directory on my external storage medium, which is a 400 GB SSD drive?
    – ciTEZen
    Apr 24 '19 at 4:11
  • You need to pass --kiln-data-dir=/path/to/another/place to Kiln. For the deb package you can configure custom arguments by following instructions here: gitlab.com/obsidian.systems/tezos-bake-monitor/blob/develop/… So, e.g. you'd echo 'KILNARGS="--kiln-data-dir=/path/to/location"' > /etc/kiln/args Apr 24 '19 at 6:29
  • You will also, of course, need to move the old data directory to this new location if you want to reuse it. If you actually ran out of disk space then your node might be stuck on invalid blocks (which requires some manual intervention) so it might be easier to just start from scratch. Apr 24 '19 at 6:36
  • Thanks! I stopped and removed the old node, changed the args, restarted kiln, created a new node and then stopped it again after this this happened i.imgur.com/w4vcSIy.png: no data is showing up in the Kiln Data folder.
    – ciTEZen
    Apr 24 '19 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.