3

I am trying to build Tezos from sources, alphanet. When doing make build-deps here is the error I get:

[ERROR] The sources of the following couldn't be obtained, aborting:
      - hidapi.1.0-1: Bad checksum

I've been getting this since 2 or 3 days. Commands I tried:

sudo apt-get update
sudo apt-get dist-upgrade

git fetch origin
git reset --hard origin/alphanet
git clean -dxf

opam update
opam upgrade

But it's still giving me the same error. Any idea why?

  • This is the same problem as in the other question, and the same fix is now on alphanet branch. – Tom Apr 12 '19 at 18:44
  • @Tom yup, I've addressed the problem to Tezos gitlab earlier today. All good now! – iNukeLaPeste Apr 12 '19 at 19:42
1

The issue was the same in nature as in question

Error compiling tezos main net hidapi

But the patch had not been included on the alphanet branch. A ticket was raised

https://gitlab.com/tezos/tezos/issues/504

And the mainnet patch was cherry picked onto the alphanet branch

https://gitlab.com/tezos/tezos/commit/4cad932e2c211cf699b9289ca167de44da3297b9

| improve this answer | |
  • Thank you for all your help! :) – iNukeLaPeste Apr 15 '19 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.