2

The error below is from starting a Tezos node (on Windows Linux Subsystem - Ubuntu 18.04) on the Alphanet:

./tezos-node run --rpc-addr 127.0.0.1:8732  
Apr  6 21:13:53 - node.main: Starting the Tezos node...  
Apr  6 21:13:53 - node.main: No local peer discovery.  
Apr  6 21:13:53 - node.main: Peer's global id: idqx3xmhXtg7fhxSaqSBcWSU1ELdPm  
Apr  6 21:13:53 - node.worker: bootstrapping chain...  
tezos-node: Error:  
          MDB_CORRUPTED: Located page was wrong type
  • Is that the first time you launch your node ? Otherwise this might happen in case of disk corruption, for instance if your node was running with the database opened in async mode and you killed the process while the node was writing. It might come from Windows, I wouldn't be surprised that write ordering was a bit looser there. – Pierre Chambart Apr 8 '19 at 21:15
  • This is the first time running the node. I did a quick Google and it looks like this is a WLS issue. – ConsentDevelopment Apr 9 '19 at 10:22
0

For anybody else using Windows and wanting to run a node then the best solution is to use VirtualBox (which if free) and install a official Linux distribution. The Tezos node will then work correctly.

| improve this answer | |
0

This is an open issue with LMDB on WSL https://gitlab.com/tezos/tezos/-/issues/229

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.